Обновление на openSUSE 11.4

Обновляюсь с openSUSE 11.3 на openSUSE 11.4. zypper dup сначала радостно снес у меня пакет liblzma0-4.999.9beta, а через мгновение rpm выяснил, что не может почему-то запуститься без lzma0, жалобно смотрел на меня и говорил:
rpm: error while loading shared libraries: liblzma.so.0: cannot open shared object file: No such file or directory
Тут все бы и закончилось, если бы я не скачал и не подсунул нужную библиотеку ему.

upd: тут в комментариях умные люди сделали правильные оргвыводы. zypper addlock liblzma0, либо обновляться с http-репозитория, а не с DVD.

3 комментария:

k0da комментирует...

Достаточно сделать zypper ar liblzma0

Linux-oiD комментирует...

Все дело в https://bugzilla.novell.com/show_bug.cgi?id=677425

Matwey V. Kornilov комментирует...

Знал бы где падать, соломки постелил бы)